OmegaDriver (temporary name)

User avatar
SuperMar10Brothe
Posts: 86
Joined: Sat Aug 11, 2018 4:43 pm

Re: OmegaDriver (temporary name)

Post by SuperMar10Brothe » Fri Nov 23, 2018 10:49 am

dale_coop, that didnt work, i doubt its the beta bug because other monsters would have this problem too.

CutterCross, What are the exact specifics of this bug? is it something to do with memory constraints? i cut out the 4th frame of animation and it works fine, i just need to rethink the walking animation to fit it into 3 frames instead of 4 and i already got an idea.
Last edited by SuperMar10Brothe on Fri Nov 23, 2018 2:49 pm, edited 2 times in total.
User avatar
dale_coop
Posts: 4076
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: OmegaDriver (temporary name)

Post by dale_coop » Fri Nov 23, 2018 11:45 am

CutterCross wrote:
Fri Nov 23, 2018 1:33 am
Your animation bug is due to the fact that your boss is higher than 4 sprites high. Anything higher than that will almost certainly cause weird issues with the animation. One way to work around this is to split your boss into 2 different smaller monsters and stack them on top of each other, but moving them together will take some finagling to figure out. Also, having your boss larger than 4 sprites HORIZONTALLY can also cause some weird issues with the color palettes, though you don't seem to be having that issue yet. Always something to keep in mind though!
Wow... do you know if Joe informed about that issue and maybe have already fixed it in the 4.1?
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE / UNDERGROUND ADVENTURE (Arcade version - Byte-Off-2019)
User avatar
SuperMar10Brothe
Posts: 86
Joined: Sat Aug 11, 2018 4:43 pm

Re: OmegaDriver (temporary name)

Post by SuperMar10Brothe » Fri Nov 23, 2018 1:57 pm

Ok so heres my solution (something i intended to do from the start anyway) making the robot pause after every step forward.
Image
User avatar
CutterCross
Posts: 394
Joined: Sat Apr 28, 2018 9:42 pm
Contact:

Re: OmegaDriver (temporary name)

Post by CutterCross » Fri Nov 23, 2018 4:40 pm

SuperMar10Brothe wrote:
Fri Nov 23, 2018 10:49 am
CutterCross, What are the exact specifics of this bug? is it something to do with memory constraints? i cut out the 4th frame of animation and it works fine, i just need to rethink the walking animation to fit it into 3 frames instead of 4 and i already got an idea.
The bug is kind of an enigma to me at the moment. All I know is that anything larger than 4 sprites wide, 4 sprites tall has the POTENTIAL to cause buggy animations/color pallet issues. I suppose it has to do with how many frames of animation you're using. (Nice solution btw!)
dale_coop wrote:
Fri Nov 23, 2018 11:45 am
Wow... do you know if Joe informed about that issue and maybe have already fixed it in the 4.1?
I don't know about that. I talked about it in my video on analyzing cutscenes, which I'm pretty sure Joe has seen. Don't know if he fixed it in 4.1.0, or if it even CAN be fixed.
Music Man:
The Tower of Turmoil: http://www.nesmakers.com/viewtopic.php?f=12&t=1348
When the Clock Hands Stall: http://www.nesmakers.com/viewtopic.php?f=52&t=2723
User avatar
dale_coop
Posts: 4076
Joined: Fri Feb 16, 2018 7:05 am
Location: France

Re: OmegaDriver (temporary name)

Post by dale_coop » Fri Nov 23, 2018 7:28 pm

CutterCross wrote:
Fri Nov 23, 2018 4:40 pm
I don't know about that. I talked about it in my video on analyzing cutscenes, which I'm pretty sure Joe has seen. Don't know if he fixed it in 4.1.0, or if it even CAN be fixed.
Ok, we'll see.... anyway, we need to keep that in mind.

SuperMar10Brothe wrote:
Fri Nov 23, 2018 1:57 pm
Ok so heres my solution (something i intended to do from the start anyway) making the robot pause after every step forward.
Image
Oh! works nice. Love it
-----
Sorry about my poor english
All I need: A Damn Fine Cup of Coffee
My games: PRESS START GAME / UNDERGROUND ADVENTURE / UNDERGROUND ADVENTURE (Arcade version - Byte-Off-2019)
User avatar
del inf3rno
Posts: 21
Joined: Thu Nov 08, 2018 2:58 am
Location: California

Re: OmegaDriver (temporary name)

Post by del inf3rno » Wed Nov 28, 2018 1:58 am

That's probably THE best mech I've ever seen in a NES title! Love this direction friend. Keep it going!
Check out my WIP project Labyrinth of Yggdrasil
User avatar
SuperMar10Brothe
Posts: 86
Joined: Sat Aug 11, 2018 4:43 pm

Re: OmegaDriver (temporary name)

Post by SuperMar10Brothe » Wed Nov 28, 2018 10:53 pm

thanks all!
User avatar
drdocker
Posts: 21
Joined: Mon Nov 12, 2018 6:27 am
Location: Seattle

Re: OmegaDriver (temporary name)

Post by drdocker » Mon Dec 03, 2018 10:00 pm

Amazing graphics! Glad you got that mech animation working, looks great with the pause.
SubCog
Posts: 12
Joined: Wed Dec 26, 2018 4:32 pm

Re: OmegaDriver (temporary name)

Post by SubCog » Wed Dec 26, 2018 8:28 pm

Wow, these graphics are nearly snes quality. Amazing art direction!
User avatar
wallmasterr
Posts: 93
Joined: Sun Jan 20, 2019 9:29 pm
Location: Scotland
Contact:

Re: OmegaDriver (temporary name)

Post by wallmasterr » Wed Jan 30, 2019 12:05 am

This looks so cool can't wait for more gameplay. you are an absolute palate swap master.
Post Reply