assingbanks.asm 90 value out of range

kriv3

New member
Hey everyone, ive loaded basic module set up persitant player, bounding box and done a backround walkable and i get this when i export and test.

Routines/system/assignbanks.asm(90): value out of range

and says i should check for a change code as well.. and i havent changed a code.

what can i do to fix this?
 

dale_coop

Moderator
Staff member
I suggest you to start over fro the beginning, new folder (unzipped nesmaker4), new project, ...
And maybe following the tutorial, in the same time: http://nesmakers.com/viewtopic.php?f=18&t=346
 

SeaFoodAndButter

New member
kriv3 said:
Hey everyone, ive loaded basic module set up persitant player, bounding box and done a backround walkable and i get this when i export and test.

Routines/system/assignbanks.asm(90): value out of range

and says i should check for a change code as well.. and i havent changed a code.

what can i do to fix this?

I have the same problem now too! My game was fine for a few days. I was building screens, loading one song, and I was compiling and testing everything just fine. Now, I have the same error as you. And I didn't change anything. I tried to reset the scripts and re-import the Basic Module that comes with NESMaker 4.0, but that didn't work either. I hope there is a fix because I've been working tirelessly for three days and pretty much had my level 1 graphics and screens all done.
 

dale_coop

Moderator
Staff member
Problem of memory maybe.
Need Joe to take a look.

You could try, remove all the input (movements) and remove the movement scripts in the from "scripts>input scripts" section too. And tests again, if it starts.
 

SeaFoodAndButter

New member
dale_coop said:
Problem of memory maybe.
Need Joe to take a look.

You could try, remove all the input (movements) and remove the movement scripts in the from "scripts>input scripts" section too. And tests again, if it starts.

Tried it, no luck. I can load "Retest last export" but can no longer use "Export and Test". I keep getting the same error: Routines/system/assignbanks.asm(90): value out of range

Do you know 1)How to remove the music from the sound/music branch? I have a new song in that branch and I want to try to delete it; and 2) do you by chance know how to look at the data banks to check the memory banks? I can't figure out where to go to look at the banks and their statuses.
 
I don't think you can delete it but you can replace it same way you added it. Right click on sound and import famitrack txt
 

SeaFoodAndButter

New member
So, I haven't figured out the fix for this. But what I have noticed is every now and then a warning screen will come up and give you the option to continue , quit, or read details about the warning. Whatever you do, do not "continue." I think that was where I messed up because I don't know enough to fix the issue. So, I advise 1) save often and create new "save as" folders as you work and 2) before you try to import anything like music, SAVE and make a copy of your work under a different name. That way you won't end up like me and lose 3-4 days of hard work. Luckily I was able to import all the graphics from my old project into a new one. I just had to spend a few hours remaking assets and rebuilding my level 1 screen by screen.
 

dale_coop

Moderator
Staff member
Or try to import the txt file music from the betaAssets\music\ folder, in NESMaker.
You may have more luck...
 

elisavage

New member
Am I missing something, or is this still a problem that isn't resolved? I get the "Routines\System\AssignBanks.asm(90): Value out of range." too, but I had not changed any sound files. It was working yesterday and now I get that error for any .MST I load. Does anyone know what would be requesting a value from AssignBanks.asm that is returning the error. I tried replacing all of he files with fresh ones from the zip file, it wrote over the old files, except for the ones that I made (project files etc) and I still get the error. I would assume it was a problem with my project file/assets, but the problem occurs across .MSTs so it would have to be a change to a file that all of the projects use? Pretty stumped.
 

cargo

spam bots yandex
It turned out that for elis case AssignBanks.asm was missing from his Nesmaker folder. Re-installing NESMaker solved his problem.
 

chronosv2

New member
Yeah, for some reason overzealous antivirus programs false positive some NESMaker files and destroy them. I've heard tales of antivirus programs wiping out large groups of files from the GameEngineData folder.
 

jakenastysnake

New member
I was getting this same error when trying to Export & Test. I was able to fix it a different way in case anybody else runs into this. In my project folder under GraphicAssets, I had been playing around with making some tilesets and saved over the original BckCHR_01.bmp file. Either it was sized improperly or I didn't convert the tiles correctly, but anyway, all I did was replace it with the ORIGINAL BckCHR_01.bmp file in the GraphicAssets folder. Hope this helps.
 

retroplayer.nl

New member
2021 BUMP :) I just had this problem after importing some backgrounds with the wrong size. Go to pixel editor > new BMP> make some new blank tiles and replace the imported backgrounds that are to big with these new ones and you are good to go. Export & test works again.
 

Normamoove

New member
Hi! I'm Zlata, living in Ukraine. I get about $240 a month. It is very little for me ((

That's why I can do it for a little money:
- Send you hot photos and videos
- send you a video of sex with an ex-boyfriend
- I can do what you say in Skype, whatsapp or other messenger

Also ready to come to you in any country for your money.
I will not leave my contacts here. Find me just on the site Dateshookp.com my nick is Zlata

Here is my photo, many like it, but not me



I hope to see you
 
Top Bottom