Player character color changes to npc color

Michael J Wolf

New member
Hey everyone. So I’m working off the adventure module and I’m doing the typical npc who gives the sword to player thing. Here is a photo of the day monsters screen details for this screen and I just can’t figure out how to keep my original player color palette different from my npc color palette. When I test the game, my player is the correct color but the second I warp him to the npc’s screen, his color palette changes to that of the npc. Any tips on what I’m doing wrong? Thank you
 

Attachments

  • D1BBA4D8-8305-419B-A071-61F9288BB80B.jpeg
    D1BBA4D8-8305-419B-A071-61F9288BB80B.jpeg
    1.9 MB · Views: 5

Logana

Active member
You need to use a separate pallet for each, the first pallet is designated for the player so you have to go back and change the monster sprite so it uses pallet 2, on each 8 by 8 tile, you can see which pallet it’s on by the grey border then set the pallet accordingly
 

Michael J Wolf

New member
You need to use a separate pallet for each, the first pallet is designated for the player so you have to go back and change the monster sprite so it uses pallet 2, on each 8 by 8 tile, you can see which pallet it’s on by the grey border then set the pallet accordingly
Thanks for the response but how and where do I set my monster sprite to use sub 2? I’m trying various tabs and can’t figure it out. Sorry if this is really elementary ha
 

Michael J Wolf

New member
You just click the second color palette, while on the tile you want to change
I know how to do that when placing tiles but for placing my actual npc (monster), I have to right click where I want him and click “place monster” and then select the monster I want to place at which point the npc is now on my screen. It never gives me an option to select the palette while placing the monster. Whereas with a tile I am placing, I just hilight the tile and click the palette on the left side of the screen that I want to use for that tile. I cannot figure out how to do that with my npc.

Am I placing my npc/monster incorrectly? This is how I learned to do it from the tutorials I’ve watched.
 

Michael J Wolf

New member
no on the screen where you make the enemy
So I think this is where I’m confused because I didn’t make the enemy from scratch. Instead, I am using the npc (monster) from the adventure module. I edited it in pixel editor to make it look how I wanted and in pixel editor it is saved under sub palette 2. So now when I load that monster in the pixel editor, it comes up in the correct colors, using sub palette 2. But then when I go to make a monster group for this npc so I can place it in the game, it comes up using my player’s colors (sub palette 1).

so I feel like there is a different screen that I can’t find where I should be able to permanently assign this npc (monster) to sub palette 2 so whenever I use this particular monster anywhere it will come up as automatically using sub palette 2 correct?

Is there a reason why I can make physical changes to this monster in pixel editor that remain constant when I make monster groups and place the character in game but the sub palette assignment doesn’t stay the same?
 

Michael J Wolf

New member
Nevermind I got it to work by going in the monsters file and editing the sub palette in there. Thank you for your help and patience. I was starting to pull my hair out on this simple thing. Ha
 
Top Bottom