Warps just take me to screen 0,0

terminalsyzygy

New member
Bit of an odd issue here because I wasn't having it before. I got a warp on screen 0,1 and in the "warp out" section of the screen info, I set it to warp to screen 1,1. But it just takes me to screen 0,0 instead.

I've set the warp in locations on each screen, tried restarting in case it was a glitch, made other warps etc, they all go to screen 0,0 no matter what.
 

Bucket Mouse

Active member
Do you have a Warp In Location set on screen 1-1? If you don't, the player sprite will warp right on the edge, which usually causes another warp.
 

dale_coop

Moderator
Staff member
Make sure you set the "Warp out x, y coords" and "Warp in x, y coords" correctly:
Let's say you have a warp tile on your screen A and wants to warp in the screen B.
- On the screen A, set the warp out x,y coords of the screen B.
- On the screen B, set the warp in x,y coords where you want your player to appear (you can also set those coords by doing a right click at the exact spot you want and chose "set warp in coords")
Now if you test, when your player will touch the warp tile from the screen A, he will be warped out to the screen B, at the location you set.
 

terminalsyzygy

New member
That seems to be exactly what I've been doing, made sure the coordinates are right on my warp out info and made sure every screen has a warp in location. No change still.
 

dale_coop

Moderator
Staff member
Warning, if your screen is part a scrolling segment (of scrolling screens), you need to set your warp out x, y coords on the first screen of that scrolling segment.
(because for scrolling screens, almost all the informations are loaded only from the 1st screen, as explained in the tutorial videos)
 
Top Bottom